failed to inject Ashita - Legacy Components active #39

Closed
opened 5 years ago by Kimotaro · 4 comments
Kimotaro commented 5 years ago

System.Exception: Failed to inject Ashita!

Error: 0
bei Ashita.Classes.AshitaInjector.<>c__DisplayClass1_0.b__0()

System.Exception: Failed to inject Ashita! Error: 0 bei Ashita.Classes.AshitaInjector.<>c__DisplayClass1_0.<LaunchConfiguration>b__0()
Owner

Make sure that:

  • Your anti-virus is not blocking Ashita from working properly.
  • Your firewall is not blocking Ashita from updating fully.
  • You are running Ashita as an Administrator. (Right-click > Run as Administrator)
  • You have all the requirements installed.

You can find a list of requirements here:
http://ashita.atom0s.com/wiki2/doku.php?id=ashitav3:systemrequirements

Make sure that: * Your anti-virus is not blocking Ashita from working properly. * Your firewall is not blocking Ashita from updating fully. * You are running Ashita as an Administrator. (Right-click > Run as Administrator) * You have all the requirements installed. You can find a list of requirements here: http://ashita.atom0s.com/wiki2/doku.php?id=ashitav3:systemrequirements
Poster

Hi :) thanks for the quick reply. I did the required steps you suggested but it is still returning the same error

System.Exception: Failed to inject Ashita!

Error: 0
bei Ashita.Classes.AshitaInjector.<>c__DisplayClass1_0.b__0()

I can start PlayOnline and play FFXI fine if I don't use Ashita. My Desktop is running Windows 10 Pro with the latest build and the AMD Radeon R9 Fury GPU.

Hi :) thanks for the quick reply. I did the required steps you suggested but it is still returning the same error System.Exception: Failed to inject Ashita! Error: 0 bei Ashita.Classes.AshitaInjector.<>c__DisplayClass1_0.<LaunchConfiguration>b__0() I can start PlayOnline and play FFXI fine if I don't use Ashita. My Desktop is running Windows 10 Pro with the latest build and the AMD Radeon R9 Fury GPU.
Owner

The code in the launcher you are hitting is:

// Inject Ashita into the remote process..
if (!ManagedInjector.InjectModule(proc, Path.Combine(AppDomain.CurrentDomain.BaseDirectory, "Ashita.dll"), false))
{
    ManagedInjector.KillProces(proc);
    throw new Exception($"Failed to inject Ashita!\r\n\r\nError: {ManagedInjector.LastError}");
}

To get the error you are getting, this is generally due to either:

  • Missing all of Ashita's install files.
  • Lacking admin permissions.
  • Lacking the required files above.

Double check that you have an Ashita.dll file in the same folder as Ashita.exe itself. There should be multiple files after the first run of Ashita.exe downloaded into the same folder. Try placing the folder in a new location, I recommend installing Ashita to:

C:\Ashita\Ashita.exe

This way everything downloads to this folder that is easy to access and refind if needed.

The code in the launcher you are hitting is: ```C# // Inject Ashita into the remote process.. if (!ManagedInjector.InjectModule(proc, Path.Combine(AppDomain.CurrentDomain.BaseDirectory, "Ashita.dll"), false)) { ManagedInjector.KillProces(proc); throw new Exception($"Failed to inject Ashita!\r\n\r\nError: {ManagedInjector.LastError}"); } ``` To get the error you are getting, this is generally due to either: * Missing all of Ashita's install files. * Lacking admin permissions. * Lacking the required files above. Double check that you have an Ashita.dll file in the same folder as Ashita.exe itself. There should be multiple files after the first run of Ashita.exe downloaded into the same folder. Try placing the folder in a new location, I recommend installing Ashita to: C:\Ashita\Ashita.exe This way everything downloads to this folder that is easy to access and refind if needed.
Owner

Closing due to inactivity.

Closing due to inactivity.
atom0s closed this issue 5 years ago
Sign in to join this conversation.
No Milestone
No Assignees
2 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.